trouble reading codes for Echostar 21.0 IR/UHF remote

Everything related to learning and capturing of IR Codes

Moderator: marcus

trouble reading codes for Echostar 21.0 IR/UHF remote

Postby IRtransUser1 » Thu 3. May 2012, 03:52

Hello,

I am using 2.0.5.28302 IRtrans SW on win7 64-bit laptop and am trying to learn IR codes for Echostar 21.0 IR/UHF remote. I am using 56K mode + learn with timing. I know for a fact that the carrier frequency is 56K. This is the only mode that results in a response on both the debug_mode and on the set-top box.

Only one out of 36 codes captured actually works on the set-top-box - the right arrow key works while the rest do not.

My remote file is attached. Maybe there are some other settings in the menus to try? Also, about 20% of the learned codes resulted in the error "code > max - this code may not work" so I had to capture them again.

Any comments that anyone can post will be well appreciated.

user1
Attachments
echoStar_21_0_56k_withTiming.rem
(16.85 KiB) Downloaded 1326 times
IRtransUser1
 
Posts: 7
Joined: Tue 1. May 2012, 13:12

Re: trouble reading codes for Echostar 21.0 IR/UHF remote

Postby IRTrans » Thu 3. May 2012, 13:13

Hi,
to learn 56kHz codes you need a device with a 56kHz Receiver or with the Universal learning receiver. If you have a device with the learning receiver use the learning receiver.

IMPORTANT: Selecting a 56Khz receiver does not convert your device into a 56Khz one. The receiver setting always needs to match your hardware.

The .rem file you have attached is learned in RAW mode - that makes analyzing the code very difficult.

What kind of IRTrans device do you use for learning?

You can also send us the remote control - then we will have a look.

IRTrans
IRTrans
Administrator
 
Posts: 2115
Joined: Mon 21. Apr 2008, 23:32

Re: trouble reading codes for Echostar 21.0 IR/UHF remote

Postby IRtransUser1 » Thu 3. May 2012, 14:26

Hello,

Thanks for your prompt response. I am using IRTrans USB V 3.8 HW for learning. Is 56k the correct receiver setting? I have tried Universal Codelearning Receiver but I cannot capture anything. Server in debug mode does not respond to Universal mode, but it does respond to 56k mode.

It is strange that the codes are captured RAW - I used 56k receiver and 'learn with timing' , not RAW mode. Obviously, I'm missing some details. I cannot send the remote - sorry.

Thanks in advance for your assistance.

user1
IRtransUser1
 
Posts: 7
Joined: Tue 1. May 2012, 13:12

Re: trouble reading codes for Echostar 21.0 IR/UHF remote

Postby IRTrans » Thu 3. May 2012, 19:51

Hi,
I am sure that 56kHz is NOT the correct setting. This setting should NEVER be changed - it has to match your Hardware (as written in red in the Dialog of the GUI Client). If it does not work with the setting "Universal Learning receiver" then you have a device with a 38kHz IR Receiver. This device cannot learn 56kHz IR Codes.

To learn the 56kHz code you need to have a device with a learning receiver. Your company should have several of those USB devices.

I am sure that you have selected "Learn RAW Code" or "Learn RAW Repeat Code" - otherwise there would not be RAW codes in the file.

Anyways, with a 38kHz receiver the codes will never work correctly.

IRTrans
IRTrans
Administrator
 
Posts: 2115
Joined: Mon 21. Apr 2008, 23:32

Re: trouble reading codes for Echostar 21.0 IR/UHF remote

Postby IRtransUser1 » Mon 7. May 2012, 22:06

Hello,

Thank you - I am using universal learning receiver mode now. I captured a file using the latest server(IRServer64 version 6.08.38). These files do not work.

I'm attaching the same pair of files using an older server (IRServer64 version 6.08.18). These files work. I can learn the ircodes for the echostar remote and I can control their set-top-box but only with the older driver.

So, I am successful with server v 6.08.18 for some reason. The two remote files look very different. For now, I will stick with the older driver.

Thanks for all the help.

user1
Attachments
newDriver.rem
.rem file for server v 6.08.38
(869 Bytes) Downloaded 1252 times
oldDriver.rem
server v 6.08.18 screenshot
(214 Bytes) Downloaded 1232 times
newDriver.rem
server v 6.08.38 screenshot
(869 Bytes) Downloaded 1242 times
IRtransUser1
 
Posts: 7
Joined: Tue 1. May 2012, 13:12

Re: trouble reading codes for Echostar 21.0 IR/UHF remote

Postby IRtransUser1 » Mon 7. May 2012, 22:30

Sorry - forgot to upload the screen shots.

Here they are.
Attachments
oldDriver.gif
old server v6.08.18 screen shot
oldDriver.gif (13 KiB) Viewed 44549 times
newDriver.gif
new server v6.08.38 screen shot
newDriver.gif (21.36 KiB) Viewed 44549 times
IRtransUser1
 
Posts: 7
Joined: Tue 1. May 2012, 13:12

Re: trouble reading codes for Echostar 21.0 IR/UHF remote

Postby IRTrans » Tue 8. May 2012, 11:21

Hmm, very strange. In generel the irserver version does not have any influence on the learned IR Codes.

Anyways we will check them and let you know what might cause that.

IRTrans
IRTrans
Administrator
 
Posts: 2115
Joined: Mon 21. Apr 2008, 23:32

Re: trouble reading codes for Echostar 21.0 IR/UHF remote

Postby IRTrans » Tue 8. May 2012, 11:29

I just had a look at both .rem files.

The codes learned with the new SW versions are RAW codes. That means you have selected "RAW Code" when learning the codes.
I have just rechecked learning with the current SW version and it works correctly. Please do not select "RAW Mode" when learning the IR codes.

The old codes have been learned using the very, very old Tray utility. It does not have any such option. However, you should no longer use it as it might not be compatible with current IRTrans devices.

Please try again to learn the codes using the current SW. You can, however, use the codes learned with the old SW together with the new SW, too.

Please let us know if it works after reinstalling the current SW.

IRTrans
IRTrans
Administrator
 
Posts: 2115
Joined: Mon 21. Apr 2008, 23:32

Re: trouble reading codes for Echostar 21.0 IR/UHF remote

Postby IRtransUser1 » Tue 8. May 2012, 15:05

Hello,

Is 'learn with timings' mode the same as RAW MODE? I selected 'learn with timings' mode, as you can see from the screen shot for the latest SW. Maybe this is my confusion. I did not select RAW MODE explicitly (see 2 additional screen shots).

Many thanks,

user1
Attachments
newDriverConfig.gif
new driver config window
newDriverConfig.gif (21.51 KiB) Viewed 44545 times
newDriver.gif
new driver learn command window
newDriver.gif (21.36 KiB) Viewed 44545 times
IRtransUser1
 
Posts: 7
Joined: Tue 1. May 2012, 13:12

Re: trouble reading codes for Echostar 21.0 IR/UHF remote

Postby IRTrans » Tue 8. May 2012, 16:30

Hi,
"Learn with Timing" is the correct mode.

Are you sure that "Learn with Timing" returns IR Codes in the RAW Format?

Please retry that using a new (empty) .rem filename.

I have tested it here and it worked correctly. So far no one had such a problem. As we have got a very large installed base such errors usually show up very early.

IRTrans
IRTrans
Administrator
 
Posts: 2115
Joined: Mon 21. Apr 2008, 23:32


Return to Learning of IR Codes

Who is online

Users browsing this forum: No registered users and 2 guests

cron