Page 1 of 1

New HTPC, Ubuntu 11.10 - Can't Send

PostPosted: Mon 7. Nov 2011, 04:41
by fergusf
I am struggling greatly with IRTrans on linux. Here's where I am at the moment.

I have irserver64 running. I have created my own remote control using irclient for my denon receiver. The definition for that remote is attached. When I run a command like "/usr/local/irtrans/irclient DENON_AVR_1909 OFF" it reaches the server (standard out is attached for the irserver). The single LED on the top of the unit blinks red once, but it does not affect the receiver. I have it 30 centimeters from the remote. The IR emitters do not produce any signal.

Here's the log for irserver
Init Server Socket done
IRServer64 Version 6.08.28
Init Events done
Opening Device: /dev/ttyUSB0
IRTRans Send Done: 1
Name : IRTrans USB
Version: U6.04.09
FW SNo : 41876
Capab : Power On; Soft ID; Dual Transmitter Drivers;
FW Cap : 0x43850db
FW Cap2: 0x8196c71
Node : /dev/ttyUSB0

Init communication ...
[ 0]: IRTrans USB U6.04.09 SN: 41876
Chdir to DB OK
Read routing OK
Read Switches OK
Open DIR: 12
Get Dirent: 584
Remote kathrein-ufs compiled: 2 Timings - 36 Commands
**** CCF Error: ac1 [See below for Remote name]
Remote ccf compiled: 20 Timings - 20 Commands
Remote dream compiled: 0 Timings - 36 Commands
Remote mce-mouse compiled: 1 Timings - 1 Commands
Remote mediacenter compiled: 1 Timings - 49 Commands
Remote dbox2 compiled: 1 Timings - 26 Commands
Remote denon_avr_1909 compiled: 1 Timings - 19 Commands
Remote irtrans compiled: 1 Timings - 33 Commands
Remote sky-hd compiled: 1 Timings - 34 Commands
Remote mce-keyboard compiled: 1 Timings - 77 Commands
Remote sky-digital compiled: 1 Timings - 31 Commands
Remote pace compiled: 2 Timings - 38 Commands
Get Dirent: 0
Duplicate Commands for ccf.1: ccf.2 ccf.3 ccf.4
Duplicate Commands for ccf.2: ccf.3 ccf.4
Duplicate Commands for ccf.3: ccf.4
Duplicate Commands for denon_avr_1909.3: denon_avr_1909.zone_2_vol_up
Duplicate Commands for denon_avr_1909.zone_vol_dwn: denon_avr_1909.zone_2_vol_dwn
Duplicate Commands for pace.0: pace.0-
Total: 12 Remotes - 32 Timings - 400 Commands - 0 Calib. Commands
0 Togglec. - 19 CCF Data - 0 CCF RAW - 1 CCF Error
IRTRans Send Done: 1
IRTRans Send Done: 1

Here's the remote definition:



Re: New HTPC, Ubuntu 11.10 - Can't Send

PostPosted: Mon 7. Nov 2011, 13:56
by IRTrans
in general there are two possible problems:

1. The Remote control has not been learned correctly. - The remote definition you have attached is not the one for your receiver. The name of your file should be denon_avr_1909.rem.
2. The settings of the IRTrans USB are incorrect. Please do not use the irclient for the device settings. Only use the GUI Client (with Mono on LINUX).


Re: New HTPC, Ubuntu 11.10 - Can't Send

PostPosted: Mon 7. Nov 2011, 15:27
by fergusf
oops, here's my remote def - does the casing matter? I've used camel casing Denon_AVR verses denon_avr?


[0][N]6[1]392 464[2]504 344[3]400 1280[4]576 1104[5]3320 1696[6]424 74520[RC]1[RP]0[FREQ]38


Re: New HTPC, Ubuntu 11.10 - Can't Send

PostPosted: Mon 7. Nov 2011, 19:33
by IRTrans
upper/lower case does not matter.

The file itself looks good. I suppose a configuration problem - e.g. internal transmitters disabled.

I would suggest checking the settings using the GUI Client (NOT irremote!).


Re: New HTPC, Ubuntu 11.10 - Can't Send

PostPosted: Tue 8. Nov 2011, 01:38
by fergusf
I plugged the IRTrans unit into a WinDoze box, installed the software, re-created the remote, copied it over to my linux computer and it worked. Thanks for the help,