Page 1 of 1

irserver64 won't daemonize on Linux

PostPosted: Tue 10. Aug 2021, 19:28
by ocgltd
I'm running Fedora 34 x86_64, with IRServer64 v 6.10.23. The irtrans software worked great on my old Fedora 26 system, but after a clean install the same config files don't seem to work. I try to start my irtrans server like this:

Code: Select all
 /usr/local/irtrans/irserver64 -timestamp -logfile /var/log/irtrans.log -loglevel 4 -daemon

And my cursor does not return (as if irserver64 was running the foreground). The log file shows:

Code: Select all
2021-08-10 15:20:41.247  Init Server Socket done
2021-08-10 15:20:41.247  IRServer64 Version 6.10.23
2021-08-10 15:20:41.247  Init Events done

Can someone suggest what is wrong? Why is irserver64 stuck (or not daemonizing)

Re: irserver64 won't daemonize on Linux

PostPosted: Wed 11. Aug 2021, 20:57
by ocgltd
Solved...I had the wrong IP for the irtrans lan

I would like to suggest that the log show a connect failure message, with retry message, and that the executable still fork so the service does not hang